diff setup.py @ 32:fdddfd434bbd 0.3.2a

- Remove dependency on distribute - Tidy up pypi package contents
author Ben Croston <ben@croston.org>
date Sat, 19 Oct 2013 21:23:45 +0100
parents a99009a7013c
children
line wrap: on
line diff
--- a/setup.py	Thu Apr 05 20:46:44 2012 +0100
+++ b/setup.py	Sat Oct 19 21:23:45 2013 +0100
@@ -1,8 +1,9 @@
 #!/usr/bin/env python
-import distribute_setup
-distribute_setup.use_setuptools()
-from setuptools import setup, find_packages
-import platform
+from distutils.core import setup
+try:
+   from distutils.command.build_py import build_py_2to3 as build_py
+except ImportError:
+   from distutils.command.build_py import build_py
 
 classifiers = ['Development Status :: 3 - Alpha',
                'Operating System :: OS Independent',
@@ -13,14 +14,10 @@
                'Topic :: Software Development',
                'Topic :: Internet :: WWW/HTTP :: WSGI']
 
-extra = {}
-if platform.python_version().startswith('3'):
-    extra['use_2to3'] = True
-
 setup(name             = 'AuthRPC',
-      version          = '0.3.1a',
-      packages         = find_packages(),
-      install_requires = 'WebOb>=1.2b3',
+      version          = '0.3.2a',
+      packages         = ['AuthRPC', 'AuthRPC.server', 'AuthRPC.client'],
+      install_requires = 'WebOb>=1.2.3',
       author           = 'Ben Croston',
       author_email     = 'ben@croston.org',
       description      = 'A JSONRPC-like client and server with additions to enable authenticated requests',
@@ -30,6 +27,4 @@
       url              = 'http://www.wyre-it.co.uk/authrpc/',
       classifiers      = classifiers,
       platforms        = ['Any'],
-      test_suite       = 'AuthRPC.tests.suite',
-      **extra)
-
+      cmdclass         = {'build_py': build_py})