diff setup.py @ 1:317e6f82c733

-
author Ben Croston <ben@croston.org>
date Tue, 30 Aug 2011 22:47:02 +0100
parents 6a61cfdf6930
children 43595981978d
line wrap: on
line diff
--- a/setup.py	Tue Aug 30 22:19:48 2011 +0100
+++ b/setup.py	Tue Aug 30 22:47:02 2011 +0100
@@ -2,6 +2,7 @@
 import distribute_setup
 distribute_setup.use_setuptools()
 from setuptools import setup, find_packages
+import platform
 
 classifiers = ['Development Status :: 3 - Alpha',
                'Operating System :: Microsoft :: Windows',
@@ -14,14 +15,13 @@
                'Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware',
                'Topic :: Internet :: WWW/HTTP :: HTTP Servers']
 
-import platform
 if platform.python_version().startswith('2'):
     # python 2.x
-    packages = ['wibble.client','wibble.server']
+    packages = find_packages()
     install_requires = ['webob>=1.0.0']
 else:
     # assume python 3.x
-    packages = ['wibble.client']
+    packages = find_packages(exclude=['wibble.server'])
     install_requires = []
 
 setup(name             = 'Wibble',