diff setup.py @ 15:3c19ae16fc7a

Renamed to AuthRPC
author Ben Croston <ben@croston.org>
date Mon, 05 Sep 2011 21:18:18 +0100
parents 685479d1f0a7
children 0dacc8e37fd9
line wrap: on
line diff
--- a/setup.py	Mon Sep 05 13:08:07 2011 +0100
+++ b/setup.py	Mon Sep 05 21:18:18 2011 +0100
@@ -8,7 +8,6 @@
                'Operating System :: OS Independent',
                'License :: OSI Approved :: MIT License',
                'Intended Audience :: Developers',
-               'Programming Language :: Python :: 2.6',
                'Programming Language :: Python :: 2.7',
                'Programming Language :: Python :: 3',
                'Topic :: Software Development',
@@ -24,22 +23,22 @@
 
 if platform.python_version().startswith('3'):
     # we can't build server with python 3
-    exclude.append('wibble.server')
+    exclude.append('authrpc.server')
     extra['use_2to3'] = True
 
-setup(name             = 'Wibble',
+setup(name             = 'AuthRPC',
       version          = '0.0.1a',
       packages         = find_packages(exclude=exclude),
       install_requires = install_requires,
       author           = 'Ben Croston',
       author_email     = 'ben@croston.org',
-      description      = 'Stick two pencils up your nose, underpants on your head then run this module.',
+      description      = 'A JSONRPC-like client and server with additions to enable authentication',
       long_description = open('README.txt').read(),
       license          = 'MIT',
-      keywords         = 'jsonrpc',
-      url              = 'http://www.wyre-it.co.uk/wibble/',
+      keywords         = 'json, rpc, wsgi, auth',
+      url              = 'http://www.wyre-it.co.uk/authrpc/',
       classifiers      = classifiers,
       platforms        = ['Any'],
-      test_suite       = 'wibble.tests.suite',
+      test_suite       = 'AuthRPC.tests.suite',
       **extra)