diff setup.py @ 8:685479d1f0a7

Tests available for both py2 and py3
author Ben Croston <ben@croston.org>
date Sun, 04 Sep 2011 23:37:41 +0100
parents ad5a8748afcf
children 3c19ae16fc7a
line wrap: on
line diff
--- a/setup.py	Thu Sep 01 19:19:03 2011 +0100
+++ b/setup.py	Sun Sep 04 23:37:41 2011 +0100
@@ -21,7 +21,6 @@
 if platform.python_version().startswith('2'):
     # we can build server with python 2
     install_requires.append('webob>=1.0.0')
-    extra['test_suite'] = 'wibble.tests.suite'
 
 if platform.python_version().startswith('3'):
     # we can't build server with python 3
@@ -41,5 +40,6 @@
       url              = 'http://www.wyre-it.co.uk/wibble/',
       classifiers      = classifiers,
       platforms        = ['Any'],
+      test_suite       = 'wibble.tests.suite',
       **extra)