diff setup.py @ 0:6a61cfdf6930

Initial version
author Ben Croston <ben@croston.org>
date Tue, 30 Aug 2011 22:19:48 +0100
parents
children 317e6f82c733
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Tue Aug 30 22:19:48 2011 +0100
@@ -0,0 +1,40 @@
+#!/usr/bin/env python
+import distribute_setup
+distribute_setup.use_setuptools()
+from setuptools import setup, find_packages
+
+classifiers = ['Development Status :: 3 - Alpha',
+               'Operating System :: Microsoft :: Windows',
+               'Operating System :: Unix',
+               "Operating System :: MacOS :: MacOS X",
+               'License :: OSI Approved :: MIT License',
+               'Programming Language :: Python :: 2.7',
+               'Programming Language :: Python :: 3',
+               'Topic :: Software Development',
+               'Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware',
+               'Topic :: Internet :: WWW/HTTP :: HTTP Servers']
+
+import platform
+if platform.python_version().startswith('2'):
+    # python 2.x
+    packages = ['wibble.client','wibble.server']
+    install_requires = ['webob>=1.0.0']
+else:
+    # assume python 3.x
+    packages = ['wibble.client']
+    install_requires = []
+
+setup(name             = 'Wibble',
+      version          = '0.0.1a',
+      packages         = packages,
+      install_requires = install_requires,
+      author           = 'Ben Croston',
+      author_email     = 'ben@croston.org',
+      description      = 'Stick two pencils up your nose, underpants on your head then run this module.',
+      long_description = open('README.txt').read(),
+      license          = 'MIT',
+      keywords         = 'jsonrpc',
+      url              = 'http://www.wyre-it.co.uk/wibble/', 
+      classifiers      = classifiers, 
+      use_2to3         = True)
+