diff setup.py @ 22:9459d63c1558

Added full support for Python 3
author Ben Croston <ben@croston.org>
date Sun, 01 Jan 2012 15:50:18 +0000
parents 4b62687da58a
children 346114023528
line wrap: on
line diff
--- a/setup.py	Sun Jan 01 11:42:25 2012 +0000
+++ b/setup.py	Sun Jan 01 15:50:18 2012 +0000
@@ -13,27 +13,18 @@
                'Topic :: Software Development',
                'Topic :: Internet :: WWW/HTTP :: WSGI']
 
-install_requires = []
-exclude = []
 extra = {}
-
-if platform.python_version().startswith('2'):
-    # we can build server with python 2
-    install_requires.append('webob>=1.0.0')
-
 if platform.python_version().startswith('3'):
-    # we can't build server with python 3
-    exclude.append('AuthRPC.server')
     extra['use_2to3'] = True
 
 setup(name             = 'AuthRPC',
-      version          = '0.0.2a',
-      packages         = find_packages(exclude=exclude),
-      install_requires = install_requires,
+      version          = '0.1.0a',
+      packages         = find_packages(),
+      install_requires = 'WebOb>=1.2b2',
       author           = 'Ben Croston',
       author_email     = 'ben@croston.org',
       description      = 'A JSONRPC-like client and server with additions to enable authenticated requests',
-      long_description = open('README.txt').read(),
+      long_description = open('README.txt').read() + open('CHANGELOG.txt').read(),
       license          = 'MIT',
       keywords         = 'json, rpc, wsgi, auth',
       url              = 'http://www.wyre-it.co.uk/authrpc/',