diff setup.py @ 0:2d587ea676bf 0.0.1a

Initial version
author Ben Croston <ben@croston.org>
date Mon, 03 Sep 2012 17:18:45 +0100
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Mon Sep 03 17:18:45 2012 +0100
@@ -0,0 +1,47 @@
+# Copyright (c) 2012 Ben Croston
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy of
+# this software and associated documentation files (the "Software"), to deal in
+# the Software without restriction, including without limitation the rights to
+# use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+# of the Software, and to permit persons to whom the Software is furnished to do
+# so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in all
+# copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+import distribute_setup
+distribute_setup.use_setuptools()
+from setuptools import setup, find_packages
+
+classifiers = ['Development Status :: 3 - Alpha',
+               'Operating System :: OS Independent',
+               'License :: OSI Approved :: MIT License',
+               'Intended Audience :: Developers',
+               'Programming Language :: Python :: 2.6',
+               'Programming Language :: Python :: 2.7',
+               'Programming Language :: Python :: 3',
+               'Programming Language :: Other',
+               'Topic :: Software Development',
+               'Intended Audience :: Education']
+
+setup(name             = 'scratch',
+      version          = '0.0.1a',
+      author           = 'Ben Croston',
+      author_email     = 'ben@croston.org',
+      description      = 'Interface Python with MIT Scratch',
+      long_description = open('README.txt').read() + open('CHANGELOG.txt').read(),
+      license          = 'MIT',
+      keywords         = 'Scratch',
+      url              = 'https://code.google.com/p/py-scratch/',
+      classifiers      = classifiers,
+      packages         = find_packages())
+