diff pyproject.toml @ 31:f77ca0963d6d 0.2.0

Fix language bug, convert to pyproject.toml
author Ben Croston <ben@croston.org>
date Wed, 12 Feb 2025 15:13:51 +0000
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/pyproject.toml	Wed Feb 12 15:13:51 2025 +0000
@@ -0,0 +1,54 @@
+[project]
+name = "zebra"
+version = "0.2.0"
+description = "A package to communicate with (Zebra) label printers"
+authors = [
+  { name = "Ben Croston", email = "ben@croston.org" },
+]
+maintainers = [
+  { name = "Ben Croston", email = "ben@croston.org" },
+]
+license = "MIT"
+#license-files = ["LICEN[CS]E*"]
+readme = "README.rst"
+requires-python = ">=3.8"
+classifiers = [
+  "Development Status :: 5 - Production/Stable",
+  "Operating System :: Microsoft :: Windows",
+  "Operating System :: Unix",
+  "Operating System :: MacOS :: MacOS X",
+  "License :: OSI Approved :: MIT License",
+  "Intended Audience :: Developers",
+  "Programming Language :: Python :: 3",
+  "Topic :: Printing",
+]
+dependencies = [
+  "pywin32; platform_system == 'Windows'",
+]
+
+[project.urls]
+homepage = "https://www.wyre-it.co.uk/zebra/"
+
+[dependency-groups]
+dev = [
+    "ruff>=0.8.4",
+]
+
+[tool.ruff.format]
+quote-style = "single"
+indent-style = "space"
+
+[build-system]
+requires = ["hatchling"]
+build-backend = "hatchling.build"
+
+[tool.hatch.build.targets.sdist]
+exclude = [
+  ".hgtags",
+]
+
+#[[tool.uv.index]]
+#name = "testpypi"
+#url = "https://test.pypi.org/simple/"
+#publish-url = "https://test.pypi.org/legacy/"
+