diff setup.py @ 8:19fd067db7ca

Added Windows support
author Ben Croston
date Mon, 15 Aug 2011 00:20:31 +0100
parents 639d9699e53c
children cc41931a7ded
line wrap: on
line diff
--- a/setup.py	Sat Aug 13 08:37:53 2011 +0100
+++ b/setup.py	Mon Aug 15 00:20:31 2011 +0100
@@ -3,14 +3,15 @@
 from distutils.core import setup
 
 try:
-   from distutils.command.build_py import build_py_2to3 as build_py
+    from distutils.command.build_py import build_py_2to3 as build_py
 except ImportError:
-   from distutils.command.build_py import build_py
+    from distutils.command.build_py import build_py
 
 classifiers = ['Development Status :: 3 - Alpha',
                'Operating System :: Microsoft :: Windows',
                'Operating System :: Unix',
                'License :: OSI Approved :: MIT License',
+               'Programming Language :: Python',
                'Programming Language :: Python :: 2.7',
                'Programming Language :: Python :: 3',
                'Topic :: Printing']
@@ -19,17 +20,21 @@
 
 if sys.platform.lower().startswith('win'):
     requires = ['win32print']
+    try:
+        import win32print
+    except:
+        raise Exception('Requires the win32print module from the pywin32 package')
 else:
     requires = []
 
 setup(name             = 'zebra',
-      version          = '0.0.1a',
+      version          = '0.0.2a',
       py_modules       = ['zebra'],
       author           = 'Ben Croston',
       author_email     = 'ben@croston.org',
       maintainer       = 'Ben Croston',
       maintainer_email = 'ben@croston.org',
-#      url              = 'http://www.wyre-it.co.uk/zebra/',
+      url              = 'http://www.wyre-it.co.uk/zebra/',
       description      = 'A package to communicate with (Zebra) label printers using EPL2',
       long_description = long_description,
       platforms        = 'Windows, Unix',