diff setup.py @ 26:20f6df6d3f42

- Fix for empty printer list - Updated to 0.0.4a - Altered to use pip
author Ben Croston <ben@croston.org>
date Sat, 16 Nov 2013 17:17:15 +0000
parents 0da94dcfdd55
children 7c132e01c281
line wrap: on
line diff
--- a/setup.py	Wed Aug 31 16:46:48 2011 +0100
+++ b/setup.py	Sat Nov 16 17:17:15 2013 +0000
@@ -20,16 +20,12 @@
 long_description = open('README').read()
 
 if sys.platform.lower().startswith('win'):
-    requires = ['win32print']
-    try:
-        import win32print
-    except:
-        raise Exception('Requires the win32print module from the pywin32 package.\nDownload from http://pypi.python.org/pypi/pywin32/')
+    install_requires = 'win32print'
 else:
-    requires = []
+    install_requires = None
 
 setup(name             = 'zebra',
-      version          = '0.0.3a',
+      version          = '0.0.4a',
       py_modules       = ['zebra'],
       author           = 'Ben Croston',
       author_email     = 'ben@croston.org',
@@ -42,6 +38,6 @@
       classifiers      = classifiers,
       license          = 'MIT',
       cmdclass         = {'build_py': build_py},
-      requires         = requires,
+      install_requires = install_requires
       )