diff setup.py @ 29:63d1260cc64e 0.1.0

- class name is now 'Zebra' instead of 'zebra' - Fix for missing win32print module in pypi - Drop python 2 support - use setuptools instead of distutils - improve documentation - Added reset(), reset_default(), autosense(), print_config_label() and print_graphic() functions
author Ben Croston <ben@croston.org>
date Tue, 01 Sep 2020 15:57:24 +0100
parents 7c132e01c281
children
line wrap: on
line diff
--- a/setup.py	Mon Apr 27 11:39:37 2015 +0100
+++ b/setup.py	Tue Sep 01 15:57:24 2020 +0100
@@ -1,11 +1,6 @@
 #!/usr/bin/env python
 import sys
-from distutils.core import setup
-
-try:
-    from distutils.command.build_py import build_py_2to3 as build_py
-except ImportError:
-    from distutils.command.build_py import build_py
+from setuptools import setup
 
 classifiers = ['Development Status :: 5 - Production/Stable',
                'Operating System :: Microsoft :: Windows',
@@ -13,30 +8,21 @@
                "Operating System :: MacOS :: MacOS X",
                'License :: OSI Approved :: MIT License',
                'Intended Audience :: Developers',
-               'Programming Language :: Python :: 2.7',
                'Programming Language :: Python :: 3',
                'Topic :: Printing']
 
-long_description = open('README').read()
-
-if sys.platform.lower().startswith('win'):
-    install_requires = 'win32print'
-else:
-    install_requires = None
-
 setup(name             = 'zebra',
-      version          = '0.0.5',
+      version          = '0.1.0',
       py_modules       = ['zebra'],
       author           = 'Ben Croston',
       author_email     = 'ben@croston.org',
       maintainer       = 'Ben Croston',
       maintainer_email = 'ben@croston.org',
       url              = 'http://www.wyre-it.co.uk/zebra/',
-      description      = 'A package to communicate with (Zebra) label printers using EPL2',
-      long_description = long_description,
+      description      = 'A package to communicate with (Zebra) label printers',
+      long_description = open('README.rst').read() + '\n' + open('CHANGELOG.rst').read(),
+      long_description_content_type = 'text/x-rst',
       platforms        = 'Windows, Unix, MacOSX',
       classifiers      = classifiers,
       license          = 'MIT',
-      cmdclass         = {'build_py': build_py},
-      install_requires = install_requires
-      )
+      install_requires = ["pywin32;platform_system=='Windows'"])